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Objectives

> After completing this module, you will be able to:

— Explain how the design analysis features of the Vivado IDE can help in FPGA design development
— List the main features of the Vivado IDE

— Describe the Vivado IDE Design flow

— Introduce the scripted Vivado IDE design flows
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Outline

» Vivado IDE Features and Benefits
» Vivado Design Suite Introduction
» Vivado Design Flow

> Summary
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Vivado IDE Solution

: . - "‘{ praject_cpu_netlist{2) - [Ciftraining/Vivado_project/cpu_netlist/project_cpu_netlistxpr] - Vivado 2013.1 = | [
) I n teract I Ve d eS I g n an d an a.l yS I S File Edit Flow Tools Window Layout View Help Search commandis
AR nREB XH DB NGO K| XL @ SDefaltLayout MR & B VK" Implementation Complete

@ Implemented Design - constrs_2 | xc7k70tfbgs76 2 (active) X
I Project Summary X | Dewice | Xi 0w x

Flow Navigator

— Timing analysis, connectivity, resource
utilization, timing constraint analysis, and entry

» RTL development and analysis
— Elaboration of HDL

Q & o
s =

4 Project Manager
ﬁ Project Settings

4 Simulation
ﬁ Simulation Settings
(Il Run Simulation

R R ]

4 Netlist Analysis
> Eﬁ’ Open Synthesized Design

2
&

4 Implementation

[#H CLBLM_R._X35Y80

— Hierarchical exploration

ﬁ Implementation Settings 7

[ Run Implementation Name: CLBLM R_X35v80 | ﬁ;

— Schematic generation ¢ oo | o oy
g {4, Edit Timing Constraints Row: 124 g .2‘

@ Report Timing Summary
W, Report Clock Networks

General | Properties

CelPins |Cels q p B

» XSIM simulator integration e e | s
. . . . Report Noise E - impl_1 xcTk7Dtbgs76-2 constrs_2 Vivado Implementation Defaults (Vivade Implementation 2013
» Synthesis and implementation in one package Sl | s
14
. . 4 Program and Debug »
> I/O pin planning Jedlll
. . iﬂ Open Hardware Session ™
— Interactive rule-based 1/0O assignment S e I

Vivado Design Flow- 5

Hierarchical Design Analysis and Implementation
Environment

© Copyright 2014 Xilinx

& XILINX » ALL PROGRAMMABLE.




Vivado’s Visualization Feature

» Visualize and debug your design at any flow stage
— Cross-probing between netlist/schematic/RTL
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Tcl Features

» Tcl Console enables the designer to actively query the design netlist

> Full Tcl scripting support in two design flows
— Project-based design flow provides easy project management by the Vivado IDE
— Non-project batch design flow enables entire flow to be executed in memory

» Journal and log files can be used for script construction
> Tcl scripting is covered in the last module of the course
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Outline

» Vivado IDE Features and Benefits
» Vivado Design Suite Introduction
» Vivado Design Flow

> Summary
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Typical vs Vivado Design Flow

_ Constraints
> Reportlng at any stage

— Robust Tcl API

» Common data model throughout the flow
— “In memory” model improves speed Optimization

Packing, Placement,
Optimization

» Interactive IP plug-n-play environment CGE > Ve B
HDL Design !
— AXI4, IP_XACT Verilog /VHDL _—" "Verilog/VHDL
» Common constraint language (XDC) S
throughout flow
— Apply constraints at any stage NetlistLinking and

Routing, Post-Route

— Generate reports at all stages ST

» Save checkpoint designs at any stage Analysis
— Netlist, constraints, place and route results -

Generation

Silicon
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What is a Netlist?

> A netlist is a description of your design

» Consists of cells, pins, port and nets

— Cells are design objects
* Instances of user modules/entities
* Instances of library elements (BELS)
= LUTs, FF, RAMs, DSP cells, etc...
» Generic technology representations of hardware functions
» Black boxes

— Pins are connection points on cells
— Ports are the top level ports of your design
— Nets make connections between pins and from pins to ports
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Netlist Objects
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Elaborated Design

» Accessed through the Flow Navigator by selecting Open ;g;t <<
Elaborated Design -

| 4 Project Manager

» Representation of the design before synthesis EF’“’J‘M Settings
= Add Sources
— Interconnected netlist of hierarchical and generic technology cells {F 1P Catalog
* Instances of modules/entities 4 TP Integrator
. . 4% Create Block Design
» Generic technology representations of hardware components 8 open Block Design
] - — anl Lod g o & Generate Block Design
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% Synthesis Settings
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Object Names in Elaborated Design

» Object names are extracted from RTL

4w (o)
— Instance and pin names of hierarchical objects - I
. . . . 43 begin
— Inferred flip-flops from underlying reg/signal/logic it (e
45 begin
« Suffix _reg is added 4 slooal petaf<- 11b0;
- 47 signal _dstf <= 1'b0;
— Nets from underlying reg/signal/logic when it makes sense - R -
50 egin
5l ’ :iqml_ ta <= signal_scc:
52 zignal st <= zignal meta;
53 end
54 end // alyhys
meta=harden_rst_i0 )
: — |
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RTL_REG_SYNC
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Synthesized Design

» Accessed through the Flow Navigator by selecting Open Synthesized Design

» Representation of the design after synthesis o oventr -
— Interconnected netlist of hierarchical and basic elements (BELS) 4 Project Manager
ﬁn roject Settings
* Instances of modules/entities c?:dj :Sc:g
1F 1F Catalog

* Basic elements

4 IP Integrator

» LUTs, flip-flops, carry chain elements, wide MUXes % create Block Design
B Open Block Design
u BIOCk RAMS, DSP Ce”S & Generate Block Design
= Clocking elements (BUFG, BUFR, MMCM, ...) S
Imulation -ettings
= |/O elements (IBUF, OBUF, I/O flip-flops) e

4 RTL Analysis

» Object names are the same as names in the elaborated netlist when possible = & opensaborated vesin

intseal_court_infemed_3 w 4 Synthesis

' [ — e 5 synthesis Settings

¥ L]

v - #» Run Synthesis

> @% Open Synthesized Design
LUTE
baud_x1E
- LUTE S0 e
= i _ct8_sn
FORE
art_beud_gen
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Implemented Design

» Accessed through the Flow Navigator by selecting Open Implemented Design

> Representation of the design during and after the implementation process
— Structurally similar to the Synthesized Design Flow Navigator «

7y = g
“A o ==

— Cells have locations, and nets are mapped to specific routing channels
4 Project Manager

% Project Settings
B Add Sources
1 F IP Catalog

4 Synthesis
{5 Synthesis Settings
& Run Synthesis
= Open Synthesized Design

4 Implementation
@ Implementation Settings

[» Run Implementation

* Open Implemented Design

4 Program and Debug
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Project Data

> All project data is stored in a project_name directory containing the following
— project_name.xpr file: Object that is selected to open a project (Vivado IDE project file)
— project_name.runs directory: Contains all run data
— project_name.srcs directory: Contains all imported local HDL source files, netlists, and XDC files
— project_name.data directory: Stores floorplan and netlist data
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Journal and Log Files

» Journal file (vivado.jou)
— Contains just the Tcl commands executed by the Vivado IDE

> Log file (vivado.log)

— Contains all messages produced by the Vivado IDE, including Tcl commands and results,
info/warning/error messages, etc.

> Location
— Linux: directory where the Vivado IDE is invoked

— Windows via icon: %APPDATA%\Xilinx\Vivado or
C:\Users\<user _name>\AppData\Roaming\Xilinx\Vivado

— Windows via command line: directory where the Vivado IDE is invoked

— From the GUI
» Select File > Open Log File
» Select File > Open Journal File
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» Vivado IDE Features and Benefits
» Vivado Design Suite Introduction
» Vivado Design Flow
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Getting Started Jump Page

> Links to create new or open existing projects

> Open example projects h —

|| File Flow Tools Window Help Q- Search

VIVADO™

Getting Started

— Used for tutorials
XILINX

» Documentation links

— Invokes PDF viewer for
* Release notes s Create New Project

Documentation

Documentation and Tutorials

\ New Project Wizard will guide you through the process
% of selecting design sources and a target device for
a new project.

Invaluable for first time users or to try new features.

» User guide

» Methodology guide
 Tutorials

Vivado Design Flow- 21
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Open Project

Open one of the most recently used projects or
any previously created project.

Open Example Project

Open one of the tutorial projects.

Manage IP

Open the IP Catalog and view available IP.

Create and customize IP to be used in a new project
or open previously customized IP to make changes.

%
o

NE
=

User Guide

More detailed info on Vivado commands, dialogs,
and buttons.

Quick Take Videos

View a series of short videos on various topics from
design flows overview to recommended methodology.

Release Notes Guide

Information about installation and new IDS features
in this release.
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New Project Creation Wizard

> Four different types of project can be . — - X
created Project Type
Specify the type of project to create. e
— RTL ‘:\’
* Front-to-back @ RTL Project
. ~ ¥ou will be able to add sources, generate IP, run RTL analysis, synthesis,
— POSt-SynthESIS implementation, design planning and analysis.
« EDIF or NGC || Do not specify sources at this time
. (7 Post-synthesis Project
- I/O plannlng ~ You will be able to add sources, view device resources, run design analysis, planning |
. . and implementation.
* For early pin teStmg | Do not specify sources at this time .
* No deS|gn sources (7 I/O PFlanning Project
_ |mp0rt PrOjeCt eXiSting prOjeCt from Project ~ Do not specify design sources. You will be able to view part/package resources.
. . .  Imported Project !
NaVIga'[Ol’, XST, and Synp“fy PrOJeCtS l ~ Create a Vivado project from a Synplify, XST or ISE Project File.

» Next, add source files, constraints files, and
select an FPGA

Vivado Design Flow- 22 © Copyright 2014 Xilinx (: XILlNX > ALL PROGRAMMABLE.



L AP
Creating a Project with HDL Sources and/or Synthesized Design

| Project Manager - wave_gen_hdl

» Define the project name and location i ——

= 5w gl A |E
» Select source files in RTL project creation

— All recognized source files, Verilog, VHDL, in the directory and
subdirectories, can be added

» Select post-synthesized netlist in Post-synthesized project
creation
— All synthesized files in the directory and subdirectories, are added e
» Select constraint files ) _
. . . . . szd;:utigel_;:do:edi‘}l:‘t::f;;; ir;c;i:)r;erspro:;ﬁllﬂing HDL and netlist files, to add to your project. Create a ":\’
— One or more constraints files including IP specific and top-level can )
be added B2 romses wk Chronbapives et oo b rclonsem Aoty |
£

[ RddFies. "] | AddDirectories... | [  cCreateFie...

» Select the family and target device, or pre-defined board

» Reference original existing files or import and copy them
into the project

Add sources from subdirectories

Next > Fiish | [ cancel
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Constraints File Management

» Constraint sets are a collection of XDC files

— A project can contain multiple constraint sets but all
must be of the same type

— For a constraints set to be applied, it must be set to
"active"

— Any constraint set can be made active by right-
clicking and selecting Make Active

> Target XDC

— The XDC file in a constraint set to which NEW
constraints are written

— Modified existing constraints are written back to the
original constraint file

Vivado Design Flow- 24 © Copyright 2014 Xilinx
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Messages: (1) 7 warnings

[=I-{s7 Design Sources (2]

- [ Verilog Header (1)

: o2 wawve gen (wave gen.v) [14)
(=-{= Constraints (1)

== constrs_1

- wave_gen_timing.xdc (target)

..... &% wave_gen_pins.xdc
-5 Simulation Sources (1)

Hierarchy IPF Sources |Librarie5 |Enm|:|-ile Order |
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Project Manager

roject_w: n - [Ci\training\Vivado\labs\Lab7\project_wave_gen\project_wave_gen.xpr] - Vivado 3
Cy \Vivado\labs\Lab7\, 1\ ]- Vivado 2012.1

» Used to manage sources, customize IP, and
view project details in the Project Summary

> Flow Navigator

File Edit Flow Tools Window Layout View Help
AR oA P D XS X L (G | SoefutLayout | % | ®
Flow Navigator « | Project Manager - project_wave_gen
o = = Sources -0 g % L Project Summary X |

: o & wat RE :
4 Project Manager

% Project Settings Messages: () Zwarnings

[ {87 Design Sources (2
-1 Verilog Header (1

& Project Settings
Project Name: project_v

ik B4

o‘!’ Add Sources Product Family: Kintex-7

» Sources view

IF 1P Catalog & @4 wave_gen (nave_aen.y) (14 Project Part: e
[#-= Constraints (1 Top Module Name: wave ge
4 Simulalien 2] Simulation Sources (1
ﬁ Simulation Settings

— Hierarchical display of sources

()} Run Simulation
2 Open Static Simulation

v Synthesis (Out-of-date

Hierarchy | IP Sources | Libraries  Compile Order : o
£, Sources | ) Templates : Part: xc7k70tfog484-2

4 RTLAnalysis e L

— |P Sources and Libraries view

« HDL and netlists including references to library and m;::::m e
location O o oo
— Gives access to constraints file Temmre || L——
> Project Summary D:m -2, T T
— Gives access to device utilization (resources), S
timing summary, and strategy information v :;

|54 Td Console | (O Messages | (] Compilation | |5 Reports (% Design Runs \

> Tcl Console, Messages, Compilation,
Reports, and Design Runs
Vivado Design Flow- 25 © Copyright 2014 Xilinx (: XILlNX > ALL PROGRAMMABLE.
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Project Settings

» General settings 9 Project Settings R . -
— Select device
General
— Target HDL language %Q
General Name: my_and2_test
- TOp mOdU|e name @ Project device: @ xc7a100tcsg324-1 (active) E]
— Language options Simulation Jorget lnnquage: | Vericg .
9 Top module name: | system_wrapper E]
. . . Synthesis Language Options
» Other settings are covered in their
res ectlve mod u |eS I) Verilog options: verilog_version=Verilog 2001 E]
p Implementation Generics/Parameters: E]
iﬁl Top library: -
Bitstream Loop count: 1,000% ¥
1P
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Flow Navigator — RTL Project

» Configure project sources Flow Navigator «

Ol g
O\ g A

— Add HDL source files, constraints files, simulation files, block designs

| 4 Project Manager

) IP |ntegl’at0r ﬁ Project Settings
. 'Jﬁ dd Sources
— Create, open, generate a block design Oﬂf;,;log
) Run SlmU|at|0n 4 1P Inteqgrator

4 Create Block Design

— XSIM simulator included ¥ Open Block Design
, : . : % |
— Behavioral, post-synthesis, post-implementation ¥ eneraie Hlock pesan
. 4 Simulation
> RTL An aIyS|S % Simulation Settings

() Run Simulation

— Open Elaborated Design button: Loads the elaborated RTL design

[

RTL Analysis

> Run Synth eS|S > [@* Open Elaborated Design
— Timing driven Qe
% Synthesis Settings
— Open Synthesized Design button: Loads synthesized netlist ® Run Synthesis

> ¥ Open Synthesized Design
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Flow Navigator — RTL Project

Flow Navigator %

Gl g
O\ [(=SEg

» Run Implement button: Runs implementation tools
— link, opt, power_opt, place, phys opt, and route

| 4 Project Manager

— Open Implemented Design button: Loads implemented design #5 Project Settings
» Program and Debug: Launches programming and debugging tools gff;i:;fs
— Open hardware session to program the FPGA T tentor

— Also can use iIMPACT program if installed to program the FPGA

4 Implementation
ﬁ Implementation Settings
[» Run Implementation

> ¥ Open Implemented Design

4 Program and Debug
ﬁ Bitstream Settings
qﬁ Generate Bitstream
nﬁf‘ Open Hardware Session
5 Launch iMPACT
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Simulation

» The Vivado simulator, XSIM, R N ——

- - - Flow Navigator « Simulation - wave_gen_behav - wave_gen X
supports RTL, netlist, and timing === sapes —oax o -0 @ [[Bumedr oo x
) ] =ica = " T PTIRAT,
i 7 IS | LRI 1 6Bla5| 161 18115| 4
. . 4 Project Manager
@ Project Settings Name Design Unit Block Typ: Name Value Data Typ
% Add S =- @ wave_gen wave_gen Verilog Mo & dk_pin_p z Logic
My G SRR +- @ dk_gen_i0 ck_gen Veriog Mo & ck_pin_n z Logic o n dkpinp
LF 1P catalog - @ rst_gen_i0 rst_gen Verilog Mo| 5 rst_pin z Logic P i ck_pin_n
. . 3, 1P Packager - @ uart_rx_i0 uart_rx Verilog Mo| 1 rxd_pin z Logic @ rst_pin
» Graphical waveform displa (1 —
. P - @ samp_ram 10 samp_ram Verilog Mo _ 1 Ib_sel_pin z Logic b
- @ resp_gen_i0 resp_gen Verilog Mo, ~ & spi_ck_pin 0 Logic 3 m td_pin
@ simuiation Settings @ char_fifo_i0 char_fifo Verilog Mo & spi_mosipn X Logic B i Ib_sel_pin
I b b tt f d d 1 (@ Run Simulation & @ uart_tx_i0 uart_tx Verilog Mo| dac_cs npin X Logic . & api.ck o
’ I r n r I n 5 - @ b_ct 0 b_ct Veriog Mo B dacdrnpn X Logic > i
O O a u O S O a g | Opea Static Smilation % @ dhx_nsamp_i0 dkx_bus Verilog Mol & % led_pins[7:0]  X000XX  Array i SPLmos_pn
. - @ dkx_pre_i0 dkx_bus Verilog Mo Brst.i X Logic m dac_cs_n_pin
. 4 RIL Aualysie @ dhx_spd_0 cloc_bus Veriog Mo e X Logic ” n dac_cr_n_pin
l I l ar e r S I I l eaS u r I n e a. S an ihsOrenbara e Uiy} &~ @ samp_gen_0 samp_gen Verilog Mo b txd_o X Logic L 11 "4 led_pins[7:0] XX00000K
J J - @ dac_spi_i0 _ dac_spi Verilog Mo ~ % 1b_sel i X Logic 5T
4 Synthesis ‘ m = % spi_dk_o 0 Logic S
i ) Synthesis Settings <5, Scope | & Sources & spi_mosi_o X Logic b rxd i
ZO O ' ' l | n bdeccesno X Logic b td_o
$ Run synthess Simulation Scope Properties —Oa X |& %ledo[7:0] X0000XX  Array . @ b_seli
=1 = 3 0 Logic T
{g¥ Open Synthesized Design B3 & dk_rx gi r
halind ' % ck_tx 0 Logic spidko
. e
4 Implementation @ wave_gen & ck_samp 0 Logic ¥ spi_mosi_o
uses can be expanaed 1o view e I e bocins
. e fiave e 4 dock locked 0O Logic " led_o[7:0] X0000000¢
[» Run Implementation | Design Unit: wave_gen % rst_ck_rx 1 Logic s
. . . . g [ b ks
5% Open Implemented Design Block Type: Verilog Module & rst_dk_tx 1 Logic e
| % rst_dk_samp 1 Logic b ck_f
| File: :/trainingfviv. joroject wav T X s » B
4 Program and Debug i 8 =
drxdatardy X Logic
.. . @ Bitstream Settings W % rx_datal7:0] X000 Awmay
) Generate Bitstream [ % send_char_val Logic
Ividers can pe inserted 1o B g Y 2
. . Td Console
visuallv isolate aroups of related  pomre s —
4| | # run 1000ns
=
WARNING: Behavioral models for independent clock FIFO configurations do
H #|  miro: (PlanAhead-1395] XSim completed. Design snapshot 'wave_gen behav' loaded.
S I g n a S | 0 . Memory (MB): peak = 670
x =
« it y
> By default, the top-level S|gnals P
= =B B E— T B ~al

are displayed
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Adding Testbench Files

» In the Flow Navigator, click Add Sources | adsouces v i

Add Sources

» Select Add or Create Simulation Sources
option and click Next

> Click on Add Files..., Add directories...
buttons if the testbench file is already
available or click on Create File... button
to create a new testbench file

This guides you through the process of adding and
creating sources for your project

_' Add or Create Constraints
() Add or Create Design Sources
6' Add or Create Simulation Sources

(") Add or Create DSP Sources

4L Add Sources H— b

Add or Create Simulation Sources
Specify simulation specific HDL files, or directories containing HOL files, to

) SE| eCt a f||e type' VerI|Og y Ver”Og Head er, add to your project. Create a new source file on disk and add it to your
SyStemver||Og1 or VHDI— Specify simulation set: | &= sim_1 -
» Browse to an existing testbench or enter Index  Name  Lbrary Location

a filename to create

Add Files... ] ’ Add Directories... ] ’ Create File...

Scan and add RTL include files into proiect
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Simulation Settings

» From the Flow Navigator, click

’ ¢~ Project Settings - pr—_g — ﬁ
Simulation Settings %y Simulation |
» Allows selection of compilation and @' o i .
S I m U I atl O n p rO p ertl eS Simulation Simulation top medule name: |two_digits_counter_on_2_7segment_dis [3
» Additional options can be entered via 59_ o e smaenties '
. . . ] . ynthesis Compilation rS|muIatlon rNetllst rﬂdvanced i
More Compilation Options field in Verlog options: =
Compilation tab and More Simulation o || cenericyParameters aptons: =)
. . . . . &E‘I -—-debug [ tvpical |
Options field in Simulation tab Bistream mt w0 )
: : : @Z —S—EaFnD?::eck - ] |
> Refer to the Vivado Design Suite n cnable fast smulation models m
. . . Maore Compilation Options
Simulation Guide (UG900) for more o '
. . Select an option above to see a description of it N
information [
i oK | [ Cancel Apply
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Outline

» Vivado IDE Features and Benefits
» Vivado Design Suite Introduction
» Vivado Design Flow

» Summary
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Summary

» Features and benefits of the Vivado IDE include

— Performance predictability
— Design analysis features that speed a designer's ability to gain timing closure

— Tcl features (commands) that make scripting easier and powerful
» Vivado tools use a common data model throughout the FPGA design process
— This yields runtime and memory resource benefits to the user
» Vivado tools support scripting in non-project batch and project-based design flows
— Vivado tools support the use of Tcl for all commands
» Vivado tools use a common constraint language (XDC) throughout the design process
— This enables synthesis optimization significantly better than the ISE software
» Pushbutton flows for most designs
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